Глава 3. Интерфейс программы

Материал из wireshark.wiki

3.1. Введение

3.2. Запуск Wireshark

Wireshark можно запустить из графического интерфейса или из командной строки.

Совет для опытных пользователей

При запуске Wireshark можно указать дополнительные настройки через командную строку. Детали можно найти в разделе 11.2 "Запуск Wireshark из командной строки".

3.3. Главное окно

Главное окно Wireshark можно увидеть после запуска захвата пакетов или после открытия сохраненного ранее файла с захваченными пакетами.


Рисунок 3.1. Главное окно Wireshark

Описание элементов главного окна Wireshark


  1. Меню (см. раздел «3.4. Меню) используется для запуска выполнения каких-либо действий, либо для задания каких-либо настроек.
  2. Главная панель инструментов (см. раздел «3.16. Главная панель инструментов») используется для быстрого доступа к чаще всего используемым действиям из меню.
  3. Панель фильтрации (см. раздел «3.17. Панель фильтрации") используется для отображения пакетов, соответствующих заданным условиям (см. раздел «6.3. Фильтрация пакетов при просмотре»).
  4. Область списка пакетов (см. раздел «3.18. Область списка пакетов") отображает основную информацию о каждом из пакетов. При выборе пакета в этой области будет изменяться содержимое области информации о пакете, области байтов пакета и области схемы пакета.
  5. Область информации о пакете (см. раздел «3.19. Область информации о пакете») отображает пакет, выбранный в области списка пакетов, в виде списка заголовков и содержимого этих заголовков.
  6. Область байтов пакета (см. раздел «3.20. Область байтов пакета») отображает пакет, выбранный в области списка пакетов, в виде шестнадцатеричных данных.
  7. Область схемы пакета (не представлена на рисунке 3.1) (см. раздел «3.21. Область схемы пакета») отображает пакет, выбранный в области списка пакетов, в виде набора блоков, которые аналогичные тем, которые используются для объяснения структуры пакетов.
  8. Строка состояния (см. раздел «3.22. Строка состояния») отображает детальную информацию о текущем состоянии программы и захваченных данных.


Совет

Расположение элементов в главном окне можно настроить, изменив параметры предпочтений. Подробности можно найти в разделе 11.5, «Параметры предпочтений».

3.3.1. Навигация в главном окне

Навигацию по списку пакетов и подробной информации о пакетах можно выполнять в том числе и только с помощью клавиатуры. В таблице 3.1, "Навигация с помощью клавиатуры", представлены комбинации клавиш с помощью которых можно перемещаться по захваченным данным. Дополнительные клавиши для навигации можно найти в таблице 3.6, «Элементы меню "Переход"».

Таблица 3.1. Навигация с помощью клавиатуры
Комбинация клавиш Описание действия
Tab или Shift + Tab Переключиться между элементами главного экрана.
При нахождении в области списка пакетов перейти к следующему пакету. При нахождении в области информации о пакете перейти к следующему элементу пакета.
При нахождении в области списка пакетов перейти к предыдущему пакету. При нахождении в области информации о пакете перейти к предыдущему элементу пакета.
Ctrl + или F8 В области списка пакетов перейти к следующему пакету, даже если список пакетов не является активным окном.
Ctrl + или F7 В области списка пакетов перейти к предыдущему пакету, даже если список пакетов не является активным окном.
Ctrl + . В области списка пакетов перейти к следующему пакету диалога (применимо для протоколов TCP, UDP и IP).
Ctrl + , В области списка пакетов перейти к предыдущему пакету диалога (применимо для протоколов TCP, UDP и IP).
Alt + или Option + ??? Перейти к следующему пакету в истории выбора.
Alt + или Option + ??? Перейти к предыдущему пакету в истории выбора.
В детальной информации о пакете закрыть выбранный элемент дерева. Если он уже закрыт, перейти к вышестоящему элементу дерева, если он имеется.
В детальной информации о пакете открыть выбранный элемент дерева. Если он уже открыт, перейти к нижестоящему элементу дерева, если он имеется.
Shift + В детальной информации о пакете открыть выбранный элемент дерева и все его поддеревья.
Ctrl + В детальной информации о пакете открыть все элементы дерева и все поддеревья.
Ctrl + В детальной информации о пакете закрыть все элементы дерева и все поддеревья.
Backspace ??? В детальной информации о пакете перейти к родительскому узлу.
Return или Enter ??? В детальной информации о пакете открыть или закрыть выбранный элемент дерева.

Список всех сочетаний клавиш, которые могут быть использованы в главном окне, можно найти по следующему пути: ПомощьО WiresharkБыстрый доступ с клавиатуры.

При наборе текста он автоматически начнет вводиться в панели фильтрации независимо от того какое окно является активным.

Онлайн-курс по Wireshark

На углубленном курсе "Архитектура современных компьютерных сетей" вы с нуля научитесь работать с Wireshark и «под микроскопом» изучите работу сетевых протоколов. На протяжении курса надо будет выполнить более пятидесяти лабораторных работ в Wireshark.

3.4. Меню

Рисунок 3.2. Меню Меню главного окна Wireshark

Некоторые пункты меню будут отключены (выделены серым цветом), если соответствующая функция недоступна. Например, нельзя сохранить файл захвата, если не был произведен захват или не был загружен хотя бы один пакет.

Главное меню содержит следующие разделы:

Файл – раздел с помощью которого можно открыть, сохранить или объединить файлы захвата, отправить на печать детальную информацию о содержимом выбранных пакетов или завершить работу с приложением Wireshark. Для более подробной информации см. раздел "3.5. Меню «Файл»".

Редактирование – раздел с помощью которого можно выполнить поиск пакетов, создать временные метки или маркировку пакетов, управлять профилями конфигурации и создать индивидуальные пользовательские настройки. Для более подробной информации см. раздел "3.6. Меню «Редактирование»".

Просмотр – раздел с помощью которого можно управлять отображением захваченных данных. В том числе можно выполнять раскраску пакетов, изменять масштабирование шрифта, изменять формат отображения пакетов в отдельном окне, управлять разворачиванием и сворачиванием деревьев в разделе с детальной информацией о пакете и так далее. Для более подробной информации см. раздел "3.7. Меню «Просмотр»".

Запуск – раздел с помощью которого можно выполнить переход к определенному пакету. Для более подробной информации см. раздел "3.8. Меню «Запуск»".

Захват – раздел с помощью которого можно запустить и остановить процесс захвата, а также можно редактировать фильтры захвата. Для более подробной информации см. раздел "3.9. Меню «Захват»".

Анализ – раздел с помощью которого можно управлять фильтрами отображения, включения или отключения анализа протоколов, пользовательскими настройками декодирования и отслеживания TCP-потоков. Для более подробной информации см. раздел 3.10. Меню «Анализ»".

Статистика – раздел с помощью которого можно получить статистику о захваченных пакетах. Для более подробной информации см. раздел 3.11. Меню «Статистика»".

Телефония – раздел с помощью которого можно получить статистику о пакетах, связанных с телефонией. Для более подробной информации см. раздел "3.12. Меню «Телефония»".

Беспроводной – раздел с помощью которого можно получить статистику о беспроводных сетях Bluetooth и IEEE 802.11 (Wi-Fi). Для более подробной информации см. раздел "3.13. Меню «Беспроводной»".

Инструменты – раздел с помощью которого Это меню содержит различные доступные в Wireshark инструменты, такие как создание правил межсетевого экрана (Firewall ACL Rules). Для более подробной информации см. раздел "3.14. Меню «Инструменты»".

Помощь – раздел с помощью которого можно получить информацию по использованию программы Wireshark. Для более подробной информации см. раздел "3.15. Меню «Помощь»".

Каждый из этих пунктов меню описан подробнее в следующих разделах.

3.5. Меню «Файл»

Рисунок 3.3. Меню «Файл»

Меню "Файл" из главного окна Wireshark


Таблица 3.2. Элементы меню «Файл»
Элемент меню Комбинация клавиш Действие
Открыть Ctrl + O Открыть созданный ранее файл с захваченными данными. Для более подробной информации см. раздел "5.2.1, Диалоговое окно «Открыть файл с захваченными данными»".
Открыть недавние Открыть один из файлов с захваченным трафиком, который был открыт ранее. При выборе пункта будет предоставлен список открытых ранее файлов.
Объединить… Объединить текущий открытый файл с захватом с другим файлом. Для более подробной информации см. раздел "5.4. Диалоговое окно «Объединение файлов с захватом»".
Импортировать из шестнадцатеричного дампа… Импортировать в новый временный файл данные из текстового файла, содержащего шестнадцатеричный дамп. Для более подробной информации см. раздел "5.5. Диалоговое окно «Импорт шестнадцатеричного дампа»".
Закрыть Ctrl + W Закрыть текущий открытый файл. Если захват не был сохранен, будет предложено это сделать (эту функцию можно отключить в настройках).
Сохранить Ctrl + S Сохранить текущий файл с захватом. Если не задано имя файла по умолчанию (возможно, с использованием опции -w <capfile>), Wireshark вызывает диалоговое окно «Сохранить файл захвата как», которое детально рассматривается в разделе "5.3.1. Диалоговое окно «Сохранить файл захвата как»".

Если текущий файл уже был сохранен, этот пункт меню становится неактивным.

Сохранение не получится выполнить во время выполнения захвата. Для возможности сохранения процесс захвата должен быть остановлен.

Сохранить как… Shift + Ctrl + S Сохранить текущий файл с захватом под любым выбранным именем. При выборе элемента будет вызвано диалоговое окно "Сохранить файл захвата как", которое детально рассматривается в разделе "5.3.1. Диалоговое окно «Сохранить файл захвата как»".
Набор файлов → Список файлов Показать список файлов в наборе файлов. При выборе элемента будет вызвано диалоговое окно "Набор файлов", которое детально рассматривается в разделе "5.6. Наборы файлов»".
Набор файлов → Следующий файл Выполнить переход к следующему файлу из набора файлов. Если файл не является частью набора или является последним в нем, этот пункт меню становится неактивным.
Набор файлов → Предыдущий файл Выполнить переход к предыдущему файлу из набора файлов. Если файл не является частью набора или является первым в нем, этот пункт меню становится неактивным.
Экспортировать указанные пакеты… Экспортировать в отдельный файл все или выбранные пакеты из текущего файла. При выборе элемента будет вызвано диалоговое окно «Экспортировать указанные пакеты». Для более подробной информации см. раздел «5.7. Экспорт данных».
Экспорт результатов анализа пакетов Экспортировать выбранные байты в текстовый файл. При выборе элемента будет вызвано диалоговое окно «Экспорт результата анализа пакетов». Экспорт возможен в файлы различных форматов (txt, CSV, XML и др.). Для более подробной информации см. раздел «5.7.3. ???».
Экспортировать байты пакета Ctrl + Shift + X ??????????
Экспортировать PUDxи в файл... ??????????
Удалить заголовки... ??????????
Экспортировать ключи сессии TLS... ??????????
Экспортировать объекты Экспортировать захваченные объекты DICOM, HTTP, IMF, SMB или TFTP в локальный файл. Вызывается соответствующий список объектов. Для более подробной информации см. раздел «5.7.7. ???».
Печать… Ctrl + P Распечатать все или выбранные пакеты из файла с захватом. При выборе элемента будет вызвано диалоговое окно «Печать». Для более подробной информации см. раздел «5.7. Печать пакетов».
Выход Ctrl + Q Выйти из Wireshark. Если файл с захватом не был сохранен, Wireshark предложит это сделать (эту функцию можно отключить в настройках).

3.6. Меню «Редактирование»

Рисунок 3.4. Меню «Редактирование»

Меню "Редактирование" из главного окна Wireshark


Таблица 3.3. Элементы меню «Редактирование»
Элемент меню Комбинация клавиш Действие
Копировать Скопировать список пакетов, детали пакета или свойства выбранного в данный момент пакета в буфер обмена.
Копировать → Как обычный текст Копировать в текстовом формате информацию о выделенном пакете, которая отображается в области списка пакетов. Возможно выделение более одного пакета.
Копировать → Как CSV Копировать в формате CSV информацию о выделенном пакете, которая отображается в области списка пакетов. Возможно выделение более одного пакета.
Копировать → Как YAML Копировать в формате YAML информацию о выделенном пакете, которая отображается в области списка пакетов. Возможно выделение более одного пакета.
Копировать → Все видимые пункты Ctrl + Alt + Shift + A Копировать в текстовом формате все данные о пакете, которые отображаются в области информации о пакете. Копируется только информация, отображенная явным образом. Объем отображаемой явным образом информации зависит от того в каком состоянии находится элемент (в свернутом или в развернутом). Если элемент развернут, будет скопировано описание элемента и его содержание. Если элемент свернут, будет скопировано только название элемента.
Копировать → Все видимые пункты выбранного дерева Копировать в текстовом формате данные о элементе пакета, который выделен и отображается в области информации о пакете. Копируется только информация, отображенная явным образом. Объем отображаемой явным образом информации зависит от того в каком состоянии находится элемент (в свернутом или в развернутом). Если элемент развернут, будет скопировано название элемента и его содержание. Если элемент свернут, будет скопировано только описание элемента. Элемент меню доступен не для всех протоколов.
Копировать → Описание Ctrl + Alt + Shift + D Копировать в текстовом формате описание элемента пакета, который выделен и отображается в области информации о пакете. Объем скопированной информации не зависит от того в каком состоянии находится элемент (в свернутом или в развернутом). Элемент меню доступен не для всех протоколов.
Копировать → Имя поля Ctrl + Alt + Shift + F Копировать в текстовом формате название элемента пакета (IP, UDP и др.), который выделен и отображается в области информации о пакете. Объем скопированной информации не зависит от того в каком состоянии находится элемент (в свернутом или в развернутом). Элемент меню доступен не для всех протоколов.
Копировать → Значение Ctrl + Alt + Shift + V Копировать в текстовом формате значения основных полей элемента пакета, который выделен и отображается в области информации о пакете. Объем скопированной информации не зависит от того в каком состоянии находится элемент (в свернутом или в развернутом). Элемент меню доступен не для всех протоколов.
Копировать → Как фильтр Ctrl + Alt + Shift + C
Найти пакет…​ Ctrl + F Вызвать панель инструментов для поиска пакета по различным критериям. Для более подробной информации см. раздел «6.8. Поиск пакетов».
Найти следующий Ctrl + N Найти следующий пакет, соответствующий параметрам из "Найти пакет...".
Найти предыдущий Ctrl + B Найти предыдущий пакет, соответствующий параметрам из "Найти пакет...".
Выполнить/отменить пометку пакета Ctrl + M Текст ячейки
Пометить все отображенное Ctrl + Shift + M Текст ячейки
Отменить пометку всего отображенного Ctrl + Alt + M Текст ячейки
Следующая пометка Ctrl + Shift + N Текст ячейки
Предыдущая пометка Ctrl + Shift + B Текст ячейки
Игнорировать/отменить игнорирование пакета Ctrl + D Текст ячейки
Игнорировать все показанные Ctrl + Shift + D Текст ячейки
Не игнорировать все показанные Ctrl + Alt + D Текст ячейки
Установить/отменить привязку ко времени Ctrl + T Текст ячейки
Отменить все привязки ко времени Ctrl + Alt + T Текст ячейки
Следующая привязка по времени Ctrl + Alt + N Текст ячейки
Предыдущая привязка по времени Ctrl + Alt + B Текст ячейки
Временной сдвиг… Ctrl + Shift + T Текст ячейки
Комментарии к пакету… Ctrl + Alt + C Текст ячейки
Удалить все комментарии к пакету Текст ячейки
Конфигурационные профили… Ctrl + Shift + A Текст ячейки
Параметры… Ctrl + Shift + P or Cmd+, (macOS) Текст ячейки

3.7. Меню «Просмотр»

Рисунок 3.5. Меню «Просмотр»

Меню "Просмотр" из главного окна Wireshark

Таблица 3.4. Элементы меню «Просмотр»
Элемент меню Комбинация клавиш Действие
Главная панель инструментов Текст ячейки
Панель инструментов фильтр Текст ячейки
Строка статуса Текст ячейки
Полный экран F11 Текст ячейки
Список пакетов Текст ячейки
Дополнительная информация о пакете Текст ячейки
Байты пакета Текст ячейки
Диаграмма пакета Текст ячейки
Формат отображения времени → Дата и время дня (1970-01-01 01:02:03.123456) Ctrl + Alt + 1 Текст ячейки
Формат отображения времени → Год, день года и время дня (1970/001 01:02:03.123456)
Формат отображения времени → Время дня (01:02:03.123456 Ctrl + Alt + 2 Текст ячейки
Формат отображения времени → Число секунд начиная с 1970-01-01 Ctrl + Alt + 3 Текст ячейки
Формат отображения времени → Секунд начиная с первого захваченного пакета: 123.123456 Ctrl + Alt + 4 Текст ячейки
Формат отображения времени → Секунд после предыдущего захваченного пакета: 1.123456 Ctrl + Alt + 5 Текст ячейки
Формат отображения времениt → Секунд после предыдущего показанного пакета: 1.123456 Ctrl + Alt + 6 Текст ячейки
Формат отображения времени → Дата и время дня UTC (1970-01-01 01:02:03.123456) Ctrl + Alt + 7
Формат отображения времени → Год, день года и время дня (1970/001 01:02:03.123456) в формате UTC Текст ячейки
Формат отображения времени → Время дня UTC (01:02:03.123456) Ctrl + Alt + 8
Формат отображения времени → Автоматически (из файла захвата)
Формат отображения времени → Секунды Текст ячейки
Формат отображения времени → Десятки секунд Текст ячейки
Формат отображения времени → Сотни секунд Текст ячейки
Формат отображения времени → Милисекунды
Формат отображения времени → Микросекунды
Формат отображения времени → Наносекунды
Формат отображения времени → Показывать секунды вместе с часами и минутами
Разрешение имен → Редактировать разрешенное имя Текст ячейки
Разрешение имен → Разрешить физические адреса Текст ячейки
Разрешение имен → Разрешить сетевые адреса Текст ячейки
Разрешение имен → Разрешить транспортные адреса Текст ячейки
Масштаб → Увеличить масштаб Ctrl + + Текст ячейки
Масштаб → Уменьшить масштаб Ctrl + - Текст ячейки
Масштаб → Обычный размер Ctrl + 0 Текст ячейки
Развернуть подчиненные деревья Shift + Текст ячейки
Свернуть подчиненные деревья Shift + Текст ячейки
Развернуть все Ctrl + Текст ячейки
Свернуть все Ctrl + Текст ячейки
Выделить цветом список пакетов
Цветовые правила… Текст ячейки
Выделить диалог цветом → Цвет 1 Ctrl + 1 Текст ячейки
Выделить диалог цветом → Цвет 2 Ctrl + 2
Выделить диалог цветом → Цвет 3 Ctrl + 3
Выделить диалог цветом → Цвет 4 Ctrl + 4
Выделить диалог цветом → Цвет 5 Ctrl + 5
Выделить диалог цветом → Цвет 6 Ctrl + 6
Выделить диалог цветом → Цвет 7 Ctrl + 7
Выделить диалог цветом → Цвет 8 Ctrl + 8
Выделить диалог цветом → Цвет 9 Ctrl + 9
Выделить диалог цветом → Цвет 10
Выделить диалог цветом → Сбросить цветовое выделение Текст ячейки
Выделить диалог цветом → Новое цветовое правило… Текст ячейки
Сбросить разметку Ctrl + Shift + W
Изменить размер столбцов Ctrl + Shift + R Текст ячейки
Внутренняя организация → Хэш таблицы диалогов Текст ячейки
Внутренняя организация → Таблицы диссекторов
Внутренняя организация → Поддерживаемые протоколы
Показать пакет в новом окне Текст ячейки
Загрузить повторно как файл формата/захвата Ctrl + Shift + F Текст ячейки
Перезагрузить Ctrl + R Текст ячейки
??????????Table 3.5. Internals menu items??????????
Menu Item Description
Conversation Hash Tables Текст ячейки
Dissector Tables Текст ячейки
Supported Protocols Текст ячейки

3.8. Меню «Запуск»

'Рисунок 3.6. Меню «Запуск»

Меню "Запуск" из главного окна Wireshark

Таблица 3.6. Элементы меню «Запуск»
Элемент меню Комбинация клавиш Действие
Перейти к пакету… Ctrl + G Текст ячейки
Перейти к связанному пакету Текст ячейки
Следующий пакет Ctrl + Текст ячейки
Предыдущий пакет Ctrl + Текст ячейки
Первый пакет Ctrl + Home Текст ячейки
Последний пакет Ctrl + End Текст ячейки
Следующий пакет в диалоге Ctrl + . Текст ячейки
Предыдущий пакет в диалоге Ctrl + , Текст ячейки
Следующий пакет в истории Alt + Текст ячейки
Предыдущий пакет в истории Alt + Текст ячейки
Автоматическая прокрутка при захвате в реальном времени

3.9. Меню «Захват»

Рисунок 3.7. Меню «Захват»

Меню "Захват" из главного окна Wireshark

Таблица 3.7. Элементы меню «Захват»
Элемент меню Комбинация клавиш Действие
Опции… Ctrl + K Текст ячейки
Старт Ctrl + E Текст ячейки
Стоп Ctrl + E Текст ячейки
Перезапуск Ctrl + R Текст ячейки
Фильтры захвата… Текст ячейки
Обновить интерфейсы F5 Текст ячейки

3.10. Меню «Анализ»

Рисунок 3.8. Меню «Анализ»

Меню "Анализ" из главного окна Wireshark

Таблица 3.8. Элементы меню «Анализ»
Элемент меню Комбинация клавиш Действие
Дисплейные фильтры… Текст ячейки
Макросы дисплейного фильтра… Текст ячейки
Показать дисплейный фильтр…
Применить как столбец Ctrl + Shift + I Текст ячейки
Применить как фильтр → Выбрано
Применить как фильтр → Не выбрано
Применить как фильтр → ... и выбранное
Применить как фильтр → ... или выбранное
Применить как фильтр → ... и не выбранное
Применить как фильтр → ... или не выбранное
Подготовить в виде фильтра → Выбрано
Подготовить в виде фильтра → Не выбрано
Подготовить в виде фильтра → ... и выбранное
Подготовить в виде фильтра → ... или выбранное
Подготовить в виде фильтра → ... и не выбранное
Подготовить в виде фильтра → ... или не выбранное
Фильтр диалога → DCCP Текст ячейки
Фильтр диалога → CIP Connection
Фильтр диалога → ВEthernet
Фильтр диалога → F5 TCP
Фильтр диалога → F5 UDP
Фильтр диалога → F5 IP
Фильтр диалога → IEEE 802.15.4
Фильтр диалога → IPv4
Фильтр диалога → IPv6
Фильтр диалога → TCP
Фильтр диалога → UDP
Фильтр диалога → ZigBee Network Layer
Фильтр диалога → PN-IO AR
Фильтр диалога → PN-IO (with data)
Фильтр диалога → PC CBA
Разрешенные протоколы... Ctrl + Shift + E Текст ячейки
Декодировать как… Ctrl + Shift + U Текст ячейки
Загрузить плагины LUA повторно… Ctrl + Shift + L
SCTP → Анализировать эту ассоциацию
SCTP → Показать все ассоциации
SCTP → Фильтровать эту ассоциацию
Следовать → Поток TCP Ctrl + Alt + Shift + T Текст ячейки
Следовать → Поток UDP Ctrl + Alt + Shift + U Текст ячейки
Следовать → Поток DCCP Ctrl + Alt + Shift + E Текст ячейки
Следовать → Поток TLS Ctrl + Alt + Shift + S Текст ячейки
Следовать → Поток HTTP Ctrl + Alt + Shift + H
Следовать → Поток HTTP/2
Следовать → Поток QUIC
Следовать → SIP-звонок
Показать байты пакета… Ctrl + Shift + O
Информация эксперта Текст ячейки

3.11. Меню «Статистика»

Рисунок 3.9. Меню «Статистика»

Меню "Статистика" из главного окна Wireshark

Таблица 3.9. Элементы меню «Статистика»
Элемент меню Комбинация клавиш Действие
Свойства файла захвата Ctrl + Alt + Shift + T Текст ячейки
Разрешенные адреса Текст ячейки
Иерархия протоколов Текст ячейки
Диалоги Текст ячейки
Конечные точки Текст ячейки
Длина пакетов Текст ячейки
Графики ввода/вывода Текст ячейки
Время ответа сервиса → СЕРВИС Текст ячейки
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Время ответа сервиса → СЕРВИС
Статистика DHCP (BOOTP) Текст ячейки
Статистика NetPerfMeter Текст ячейки
Программы ONC-RPC Текст ячейки
29West Текст ячейки
ANCP Текст ячейки
BACnet → Пакеты, отсортированные по ID экземпляра Текст ячейки
BACnet → Пакеты, отсортированные по IP-адресу
BACnet → Пакеты, отсортированные по типу объекта
BACnet → Пакеты, отсортированные по типу службы
Collectd Текст ячейки
DNS Текст ячейки
График потока Текст ячейки
HART-IP Текст ячейки
HPFEEDS Текст ячейки
HTTP → Счетчик пакетов Текст ячейки
HTTP → Запросы
HTTP → Распределение нагрузки
HTTP → Запросить последовательности
HTTP2 Текст ячейки
Sametime Текст ячейки
График потока TCP → Временная последовательность (Stevens) Текст ячейки
График потока TCP → Временная последовательность (tcptrace)
График потока TCP → Пропускная способность
График потока TCP → Время передачи от отправителя к получателю и обратно
График потока TCP → Масштабирование окна
Потоки UDP-мультикаст Текст ячейки
Reliable Server Pooling (RSerPool) Текст ячейки
SOME/IP → SOME/IP Messages
SOME/IP → SOME/IP-SD Entries
F5 → Virutal Server Distribution Текст ячейки
F5 → tmm Distribution
Статистика IPv4 → Все адреса Текст ячейки
Статистика IPv4 → Назначения и порты
Статистика IPv4 → Типы IP протоколов
Статистика IPv4 → Адреса отправителей и получателей
Статистика IPv6 → Все адреса Текст ячейки
Статистика IPv6 → Назначения и порты
Статистика IPv6 → Типы IP протоколов
Статистика IPv6 → Адреса отправителей и получателей

3.12. Меню «Телефония»

Рисунок 3.10. Меню «Телефония»

Меню "Телефония" из главного окна Wireshark

Таблица 3.10. Элементы меню «Телефония»
Элемент меню Комбинация клавиш Действие
Вызовы VoIP Текст ячейки
ANSI → Статистика A-I/F BAMAP Текст ячейки
ANSI → Статистика A-I/F DTAP
ANSI → Map Operation Statistics
GSM → A-Interface BSSMAP Текст ячейки
GSM → A-Interface DTAP Call Control
GSM → A-Interface DTAP GPRS Mobility MAnagement
GSM → A-Interface DTAP GPRS Session Management
GSM → A-Interface DTAP Mobility Management
GSM → A-Interface DTAP Radio Resource Management
GSM → A-Interface DTAP Short Message Service
GSM → A-Interface DTAP Special Conformance Testing Functions
GSM → A-Interface DTAP Supplementary Services
GSM → A-Interface DTAP SACCH
GSM → CAMEL Messages and Response Status
GSM → MAP Operation
c
Анализ потока IAX2 Текст ячейки
Сообщения ISUP Текст ячейки
LTE → RLC график Текст ячейки
LTE → Статистика MAC
LTE → Статистика RLC
MTP3 → Статистика MTP3 Текст ячейки
MTP3 → Сводка MTP3
Osmux Текст ячейки
Osmux → Счетчик пакетов
RTP → Потоки RTP Текст ячейки
RTP → Анализ потока RTP
RTP → RTP-плейер
RTSP → Счетчик пакетов
SCTP → Анализировать эту ассоциацию Текст ячейки
SCTP → Показать все ассоциации
Операции SMPP Текст ячейки
Сообщения UCP Текст ячейки
F1AP
NGAP
Потоки SIP Текст ячейки
H.225 Текст ячейки
Статистика SIP Текст ячейки
Счетчик пакетов WAP-WSP Текст ячейки

3.13. Меню «Беспроводной»

Рисунок 3.11. Меню «Беспроводной»

Меню "Беспроводной" из главного окна Wireshark

Таблица 3.11. Элементы меню «Беспроводной»
Элемент меню Комбинация клавиш Действие
Атрибуты сервера Bluetooth ATT Текст ячейки
Устройства Bluetooth Текст ячейки
Общие сведения о Bluetooth HCI Текст ячейки
Трафик WLAN Текст ячейки

3.14. Меню «Инструменты»

Рисунок 3.12. Меню «Инструменты»

Меню "Инструменты" из главного окна Wireshark

Table 3.12. Элементы меню «Инструменты»
Элемент меню Комбинация клавиш Действие
ACL-правила межсетевого экрана Текст ячейки
Учетные данные Текст ячейки
Lua → Console Текст ячейки
Lua → Evaluate
Lua → Manual
Lua → Wiki

3.15. Меню «Помощь»

Рисунок 3.13. Меню «Помощь»

Меню "Помощь" из главного окна Wireshark

Таблица 3.13. Элементы меню «Помощь»
Элемент меню Комбинация клавиш Действие
Содержание F1 Текст ячейки
Страницы документации →  Текст ячейки
Веб-сайт Текст ячейки
ЧАВО Текст ячейки
Спросить (B&O)
Загрузки Текст ячейки
Вики Текст ячейки
Образцы захватов Текст ячейки
Проверить обновления...
О Wireshark Текст ячейки

3.16. Главная панель инструментов

Рисунок 3.14. Главная панель инструментов

Главная панель инструментов из главного окна Wireshark

Таьблица 3.14. Элементы главной панели инструментов
Пиктограмма Действие Элемент меню Действие
Начать захват пакетов Захват → Старт Текст ячейки
Остановить захват пакетов Захват → Стоп Текст ячейки
Перезапустить текущий захват Захват → Перезапуск Текст ячейки
Опции захвата​ Захват → Опции Текст ячейки
Открыть файл с захваченными данными Файл → Открыть… Текст ячейки
Сохранить этот файл захвата Файл → Сохранить как… Текст ячейки
Закрыть этот файл захвата Файл → Закрыть Текст ячейки
Загрузить этот файл повторно Просмотр → Перезагрузить Текст ячейки
Найти пакет​ Редактирование → Найти пакет… Текст ячейки
Перейти к предыдущему пакету Запуск → Предыдущий пакет Текст ячейки
Перейти к следующему пакету Запуск → Следующий пакет Текст ячейки
Перейти к указанному пакету​ Запуск → Перейти к пакету… Текст ячейки
Перейти к первому пакету Запуск → Первый пакет Текст ячейки
Перейти к последнему пакету Запуск → Последний пакет Текст ячейки
Автоматическая прокрутка к последнему пакету при захвате в реальном времени Запуск → Автоматическая прокрутка при захвате в реальном времени Текст ячейки
Выводить пакеты на экран, используя цветовые правила Просмотр → Выделить цветом список пакетов Текст ячейки
Увеличить текст главного окна Просмотр → Масштаб  → Увеличить масштаб Текст ячейки
Ужать текст главного окна Просмотр → Масштаб  → Уменьшить масштаб Текст ячейки
Вернуть текст главного окна к его нормальному размеру Просмотр → Масштаб  → Обычный размер Текст ячейки
Изменить размер столбцов списка пакетов для полного размещения содержимого Просмотр → Изменить размер столбцов Текст ячейки

3.17. Панель фильтрации

Table 3.15. Filter toolbar items
Toolbar Icon Name Description
Bookmarks Текст ячейки
Filter Input Текст ячейки
Clear Текст ячейки
Apply Текст ячейки
Recent Текст ячейки
Add Button Текст ячейки
Squirrels Filter Button Текст ячейки

3.18. Область списка пакетов

Table 3.16. Related packet symbols
Текст ячейки
Текст ячейки
Текст ячейки
Текст ячейки
Текст ячейки
Текст ячейки
Текст ячейки
Текст ячейки
Текст ячейки

3.19. Область информации о пакете

3.20. Область байтов пакета

3.21. Область схемы пакета

3.22. Строка состояния